Firefox 44 gets override weak security certificate errors

download mod apk

When you open a web page currently in the Firefox browser that is using weak cryptography, then you will be redirected to an error page stating that the connection to the page failed.

Mozilla launched the new error page in Firefox 33. Before that, Firefox offered the means to enforce a connection to the site in question.

The reason for the failure to connect is given, for instance “secure connection failed”, as is an option to try to connect to the site again or to report the error.

What’s not there though is an option to override it. While it is safe to block the connection in these cases, it is problematic that there is no override available.

mod apk

secure connection failed firefox

If you look how Chrome or Internet Explorer handle this, you will notice that they provide overrides to enable users to connect to the site anyway.

This can be useful if you need to sign in to the web interface of a local router for instance that has not received updates in years and is still using cryptography that is considered weak nowadays.

Without an override in place, you would not be able to connect to the interface using Firefox. Mozilla implemented a fallback option in the preferences:

  1. Type about:config in Firefox’s address bar and hit enter.
  2. Confirm you will be careful.
  3. Locate the preference security.tls.insecure_fallback_hosts
  4. Double-click on it and add the hostname of the site you want to add exceptions for, e.g.
  5. Make sure the hostname matches exactly, as and are different.

While that makes sense for sites that you connect to regularly, you may not want to add hostnames permanently to the configuration if you only need temporary access.

While you could edit the preference regularly to turn exceptions on or off when the need arises, it may not be comfortable depending on how often you need to make changes to the preference.

Mozilla will make things easier for Firefox users starting with Firefox 44. The organization plans to add an override to Firefox’s secure connection error page.


As you can see on the screenshot above, the new error page will feature an advanced button that you may click on to display an option to visit the site that is considered insecure.

Please note that this is a mockup and subject to change. The planned change would allow Firefox users to bypass weak security errors to visit sites in the browser directly.

Up until now, I have used other browsers to connect to these pages instead if I only needed temporary access to them. (via Sören Hentzschel)

Now You: How do you handle insecure connection errors in Firefox?


Article Name

Firefox 44 gets override weak security certificate errors


Martin Brinkmann


Mozilla plans to improve the weak security error page in Firefox when connecting to insecure https sites by adding an override to it.

About Martin Brinkmann

Martin Brinkmann is a journalist from Germany who founded Ghacks Technology News Back in 2005. He is passionate about all things tech and knows the Internet and computers like the back of his hand. You can follow Martin on Facebook, Twitter or Google+

You are here: Home > Firefox > Firefox 44 gets override weak security certificate errors

This entry passed through the Full-Text RSS service – if this is your content and you’re reading it on someone else’s site, please read the FAQ at